利用者同士で解決するサポートコミュニティOKBIZ. for Community Support

  • このエントリーをはてなブックマークに追加

締切り済みの質問

このQ&Aは役に立ちましたか?

CUPS用ドライバーをARM CPUで利用するには

現在DCP-J952Nを使用していますが、ARMチップのlinuxで利用されている方はおりますでしょうか。
ダウンロードページに存在するのはIntelチップ用しかないので、cupsでppdファイルを利用して設定したのですが、印刷されません。

※OKWaveより補足:「ブラザー製品」についての質問です。

投稿日時 - 2014-12-24 17:38:29

QNo.8869079


困ってます

回答 (1件中 1~1件目)

>ARMチップのlinux

よく言われる事ですがlinuxってだけでは回答のしようがありません。
ARMをサポートしているデスビは結構多いですしVerによっても異なります。

Ubuntuですと言ってもサポートが終了しているVerを言ってきてまともに動きませんなんて日常茶飯事。
このプリンター・スキャナーカテも似たようなもんですが…

DCP-J952Nはrpmとdebパッケージをサポートしているからred-hat系やDebian(Ubuntu含む)これらの派生デスビならをCUPSで使える筈なんだけどね。

http://support.brother.co.jp/j/b/downloadtop.aspx?prod=dcpj952n

それ以外のSlackware系とか独立系はユーザー同士で頑張っている。

因みにもしUbuntuを使っているならば
Ubuntu日本語フォーラム
https://forums.ubuntulinux.jp/

で使用しているPCやUbuntuのバージョンなど動作環境を明記した上で質問した方が良い。
ARMを使っている人も結構いるよ。

他の場合でも同様なサイトがある筈ですから自分で見つけてくれ。

投稿日時 - 2014-12-24 21:01:55

ANo.1

お礼

ご回答ありがとう御座います。

本日お教え頂いた"Ubuntu日本語フォーラム"をいろいろ検索して見たのですが、まだ解決策に至るヒントを見い出せていません。
こちらが使用しているOSはDebian Jessieでインストールしたcupsは1.7.2です。
armのアーキテクチャはam7lです。

Brotherのホームページにあるx86用と注意書きのあるdebモジュールをarm上にインストールし、ppdとコンパイルしたwrapperを該当するディレクトリに配置させました。deviceURIも各種試したのですが、印刷されるまではできていません。Googleでもいろいろ探してヒントらしきものを試験してみましたが成功までに至っておりません。

設定も使用しているcupあるいはOSのバージョン等で異なるようですが、皆様でのうまく行かなかった例も含めて経験を共有して頂けば幸いです。

投稿日時 - 2014-12-25 20:57:47

このQ&Aは役に立ちましたか?